TOJ 3508.Minimum Scalar Product

题目链接:http://acm.tju.edu.cn/toj/showp3508.html


3508.    Minimum Scalar Product
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1942    Accepted Runs: 586



You are given two vectors v1 = (x1, x2, ..., xn) and v2 = (y1y2, ..., yn). The scalar product of these vectors is a single number, calculated as x1y1x2y2 + ... + xnyn

Suppose you are allowed to permute the coordinates of each vector as you wish. Choose two permutations such that the scalar product of your two new vectors is the smallest possible, and output that minimum scalar product.

Input

The first line of the input file contains integer number T - the number of test cases. For each test case, the first line contains integer number n. The next two lines contain integers each, giving the coordinates of v1 and v2 respectively. Limits: = 10, 100 ≤ ≤ 800, -100000 ≤ xiyi ≤ 100000.

Output

For each test case, output a line 

Case #XY

where X is the test case number, starting from 1, and Y is the minimum scalar product of all permutations of the two given vectors.

Sample Input

2
3
1 3 -5
-2 4 1
5
1 2 3 4 5
1 0 1 0 1

Sample Output

Case #1: -25
Case #2: 6



Source: TJRAC Team Selection 2010 (4)
Submit   List    Runs   Forum   Statistics


水题,但是真不好意思说是水题了,WA了好几次,实际上就是因为太马虎没意识到最终结果超出了int的范围。。惨痛的教训啊。。


#include <stdio.h>
#include <algorithm>
using namespace std;
int main(){
	int t,n;
	long long vector1[801],vector2[801];
	long long product;
	scanf("%d",&t);
	for(int cast=1;cast<=t;cast++){
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			scanf("%lld",&vector1[i]);
		for(int i=0;i<n;i++)
			scanf("%lld",&vector2[i]);
		sort(vector1,vector1+n);
		sort(vector2,vector2+n);
		product=0;
		for(int i=0;i<n;i++)
			product+=(vector1[i] * vector2[n-i-1]);
		printf("Case #%d: %lld\n",cast,product);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值