题目链接:http://acm.tju.edu.cn/toj/showp3508.html
Time Limit: 1.0 Seconds Memory Limit: 65536K
Total Runs: 1942 Accepted Runs: 586
You are given two vectors v1 = (x1, x2, ..., xn) and v2 = (y1, y2, ..., yn). The scalar product of these vectors is a single number, calculated as x1y1+ x2y2 + ... + xnyn.
Suppose you are allowed to permute the coordinates of each vector as you wish. Choose two permutations such that the scalar product of your two new vectors is the smallest possible, and output that minimum scalar product.
Input
The first line of the input file contains integer number T - the number of test cases. For each test case, the first line contains integer number n. The next two lines contain n integers each, giving the coordinates of v1 and v2 respectively. Limits: T = 10, 100 ≤ n ≤ 800, -100000 ≤ xi, yi ≤ 100000.
Output
For each test case, output a line
Case #X: Y
where X is the test case number, starting from 1, and Y is the minimum scalar product of all permutations of the two given vectors.
Sample Input
2 3 1 3 -5 -2 4 1 5 1 2 3 4 5 1 0 1 0 1
Sample Output
Case #1: -25 Case #2: 6
Source: TJRAC Team Selection 2010 (4)
水题,但是真不好意思说是水题了,WA了好几次,实际上就是因为太马虎没意识到最终结果超出了int的范围。。惨痛的教训啊。。
#include <stdio.h>
#include <algorithm>
using namespace std;
int main(){
int t,n;
long long vector1[801],vector2[801];
long long product;
scanf("%d",&t);
for(int cast=1;cast<=t;cast++){
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%lld",&vector1[i]);
for(int i=0;i<n;i++)
scanf("%lld",&vector2[i]);
sort(vector1,vector1+n);
sort(vector2,vector2+n);
product=0;
for(int i=0;i<n;i++)
product+=(vector1[i] * vector2[n-i-1]);
printf("Case #%d: %lld\n",cast,product);
}
}