TOJ 2836.River Hopscotch(二分好题)

题目链接:http://acm.tju.edu.cn/toj/showp2836.html


2836.    River Hopscotch
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 396    Accepted Runs: 145     Multiple test files



Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤  L ≤ 1,000,000,000). Along the river between the starting and ending rocks,  N (0 ≤  N ≤ 50,000) more rocks appear, each at an integral distance  Di from the start (0 <  Di <  L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

* Line 1: Three space-separated integers:  LN, and  M

* Lines 2..N + 1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

* Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Input Details

5 rocks at distances 2, 11, 14, 17, and 21. Starting rock at position 0, finishing rock at position 25.

Output Details

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).



Source: USACO 2006 December Competition
Submit   List    Runs   Forum   Statistics

挺好的一道二分的题目,做完这道题对二分的理解上了一个台阶,思路是采用二分,以中间值为基准去找需要满足这个值最少去除的rock数,如果这个rock数比题目中的M大,则说明中值取得太大,反之取得太小,因此并不是直接岁数组的二分,挺不错的一道题。


#include <stdio.h>
#include <algorithm>
using namespace std;
int main(){
	int roc[50003],l,n,m,right,left,ans=0,mid;
	scanf("%d%d%d\n",&l,&n,&m);
	for(int i=1;i<=n;i++)
		scanf("%d",&roc[i]);
	left=roc[0]=0;
	right=roc[n+1]=l;
	sort(roc,roc+n+2);
	while(left<=right){
		int flag=0,sum=0;
		mid=(left+right)/2;
		for(int i=1;i<=n;i++)
			if(roc[i]-roc[flag]<mid)
				sum++;
			else 
				flag=i;
		if(sum>m)
			right=mid-1;
		else
			left=mid+1;
	}
	printf("%d\n",right);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值