TOJ 1753.Hamming Problem

题目链接:http://acm.tju.edu.cn/toj/showp1753.html


1753.    Hamming Problem
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 535    Accepted Runs: 251     Multiple test files



For each three prime numbers p1, p2 and p3, let's define Hamming sequence Hi(p1, p2, p3), i=1, ... as containing in increasing order all the natural numbers whose only prime divisors are p1, p2 or p3.

For example, H(2, 3, 5) = 2, 3, 4, 5, 6, 8, 9, 10, 12, 15, 16, 18, 20, 24, 25, 27, ...

So H5(2, 3, 5)=6.

Input

In the single line of input there are space-separated integers p1 p2 p3 i.

Output

The output must contain the single integer - Hi(p1, p2, p3). All numbers in input and output are less than 1018.

Sample Input

7 13 19 100

Sample Output

26590291



Source: Northeastern Europe 2000 Far-Eastern Subregion
Submit   List    Runs   Forum   Statistics


关于丑数的一道题,丑数相关知识见:http://blog.csdn.net/acm_zl/article/details/10613073

知道怎么求丑数,这道题就很简单了:


#include <stdio.h>
long long Min(long long a,long long b,long long c){
	if(a<b)
		return a<c?a:c;
	else
		return b<c?b:c;
}
int main()
{ 
	int num2,num3,num5,n;
	while(~scanf("%d%d%d%d",&num2,&num3,&num5,&n)){
		const int Max=n;
		long long Prime[Max+1];
		int index2=0,index3=0,index5=0;
		Prime[0]=1;
		for(int i=0;i<n;i++){
			long long minnum=Min(Prime[index2]*num2,Prime[index3]*num3,Prime[index5]*num5);
			if(minnum==Prime[index2]*num2)
				index2++;
			if(minnum==Prime[index3]*num3)
				index3++;
			if(minnum==Prime[index5]*num5)
				index5++;	
			Prime[i+1]=minnum;
		}
		printf("%lld\n",Prime[n]);
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值