TOJ 1825.Filling Out the Team

题目链接:http://acm.tju.edu.cn/toj/showp1825.html


1825.    Filling Out the Team
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1743    Accepted Runs: 730



Over the years, the people of the great city of Pittsburgh have repeatedly demonstrated a collective expertise at football second to none. Recently a spy has discovered the true source of the city's football power-a wizard known only as "Myron," who is infallible at selecting the proper position at which each player will excel.

Now that you know the source of Pittsburgh's wisdom, you are determined to provide your school's football team with a computer program that matches the wisdom of "Myron." You have consulted with the best football minds you can find, and they have dispensed their wisdom on the slowest speed, minimum weight, and minimum strength required to play each position.

Using this knowledge, you will develop a program that reads in several players physical attributes and outputs what position(s) they are able to play.

Input

Each line of the input file will list the attributes for one player:

<speed> <weight> <strength>

Each number will be a real-valued number. The file will end with a line reading "0 0 0"

Output

For each player, you will output one line listing the positions that player can play. A player can play a position if each of their attributes is greater or equal to the minimum for weight and strength, and less than or equal to the slowest speed. If a player can play multiple positions, output them in the order listed above, separated by a single space. You're demanded to leave an extra space at the end of the line. If a player can play no positions, write "No positions" on the line with no tailing space.

Sample Input

4.4 180 200
5.5 350 700
4.4 205 350
5.2 210 500
0 0 0

Sample Output

Wide Receiver 
Lineman 
Wide Receiver Quarterback 
No positions



Source: Mid Atlantic North America 2004
Submit   List    Runs   Forum   Statistics

水题,写几个if-else就好。


#include <stdio.h>
int main(){
	double speed;
	int tag1,tag2,tag3,w,s;
	while(~scanf("%lf%d%d",&speed,&w,&s)&&(speed+w+s)){
		tag1=tag2=tag3=0;
		if(speed<=4.5&&w>=150&&s>=200) tag1=1;
		if(speed<=6.0&&w>=300&&s>=500) tag2=1;
		if(speed<=5.0&&w>=200&&s>=300) tag3=1;
		if(tag1)
			if(tag2)
				if(tag3)
					printf("Wide Receiver Lineman Quarterback \n");
				else
					printf("Wide Receiver Lineman \n");
			else
				if(tag3)
					printf("Wide Receiver Quarterback \n");
				else
					printf("Wide Receiver \n");
		else
			if(tag2)
				if(tag3)
					printf("Lineman Quarterback \n");
				else
					printf("Lineman \n");
			else
				if(tag3)
					printf("Quarterback \n");
				else
					printf("No positions\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值