TOJ 3455.Diamonds

题目链接:http://acm.tju.edu.cn/toj/showp3455.html


3455.    Diamonds
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 327    Accepted Runs: 140     Multiple test files



John and Kate found 10 diamonds, each of which has an integer value. They want to divide these diamonds into two parts, one of which will belong to John and the other will belong to Kate. Of cause the two friends both holp to get as more valuable as possible. For equity reason, they will devide these diamonds in such way: at first John divide these diamonds into to part freely, then Kate take one part, and the other part belongs to John. Now the question is how much value can John get at most?

Input

The first line of input is an integer T (1 ≤ T ≤ 100) indicate the number of test cases. Then T lines follows, each line has 10 integers, all of which are integers and between 0 and 1000 (inclusively) represent the value of the ten diamonds.

Output

For each test cases, output a single line: the most value John can get.

Sample Input

1
1 1 1 2 1 1 1 1 1 1

Sample Output

5

10颗钻石总共有2^9种可能性,也不多,直接暴力遍历一遍就行了。

#include <stdio.h>
#include <algorithm>
using namespace std;
int main(){
    int n,s1,s2,tmp,a[10];
    scanf("%d",&n);
    while(n--){
        for(int i = 0;i < 10;i++)
            scanf("%d",&a[i]);
        int ans = 0;
        for(int j = 0;j < (1 << 9);j++){
            s1 = s2 = 0;
            for(int i = 0;i < 10;i++)
                if(j & (1 << i))
                    s1 += a[i];
                else
                    s2 += a[i];
            ans = max(ans, min(s1,s2));
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值