hdoj 1597 find the nth digit 大水题!!

                           find the nth digit

                             Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                   Total Submission(s): 8404    Accepted Submission(s): 2398


Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 

Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 

Output
对于每个N,输出S中第N个对应的数字.
 

Sample Input
  
  
6 1 2 3 4 5 10
 

Sample Output
  
  
1 1 2 1 2 4
 
AC CODE:
#include<iostream>
#include<math.h>
using namespace std;
int main()
{
    long long int sum,temp,j,i,k;
    __int64 n;
    scanf("%d",&k);
    while(k--)
    {
        scanf("%I64d",&n);
        for(i=(int)sqrt(2*n)-1;;i++)
        if(i*(i+1)>=2*n)
        break;
        //printf("%d#\n",i);
        temp=(i-1)*i/2;
        //if(n>temp)
        n-=temp;
        if(n%9==0)
        printf("9\n");
        else
        printf("%d\n",n%9);
    }
    return 0;
}

题中说不超过64位,是个坑!!不用64位整形提交过不了,哎~大水题,不解释。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值