hdu2492Ping pong

Ping pong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3780    Accepted Submission(s): 1407


Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). 

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?
 

Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.


Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).
 

Output
For each test case, output a single line contains an integer, the total number of different games.
 

Sample Input
  
  
1 3 1 2 3
 

Sample Output
  
  
1
题意:有一行乒乓球队员比赛要选择裁判,对于裁判要求是:
1.裁判水平要大于一个队员,小于另一个队员
2.裁判到两个队员距离之和要小于两个队员之间的距离。
求这样的比赛有多少种
 
思路:只要算出各个队员前面有多少个大于和小于它的,后面有多少个数大于和小于它的。再用它前面小于它的数的数量*后面大于它的数的数量+前面大于它~*后面小于它~就好,可以用两次树状数组来实现。

代码:
#include<iostream>
using namespace std;
#include<cstring>
#include<cstdio>
__int64 c[100005],a[100005],d[100005],f[100005],t[100005],h[100005];
__int64 sum(__int64 x)
{
    __int64 s=0;
    while(x>0)
    {
        s+=c[x];
        x-=x&(-x);
    }
    return s;
}
void updata(__int64 i,__int64 j)
{
    while(i<=100001)
    {
        c[i]+=j;
        i+=i&(-i);
    }
}
int main()
{
    int p;
    int max=100003;
    scanf("%d",&p);
    while(p--)
    {
        memset(c,0,sizeof(c));
        int n;
        scanf("%d",&n);
        int i;
        for(i=1;i<=n;i++)
        {
            scanf("%I64d",&a[i]);
        }
        for(i=1;i<=n;i++)
        {
            updata(a[i],1);
            d[i]=sum(max)-sum(a[i]);   //求前边比它大的数的数量
            f[i]=sum(a[i]-1);         //求前边比它小的数的数量
        }
        memset(c,0,sizeof(c));          //清零
        for(i=n;i>=1;i--)
        {
            updata(a[i],1);            //求后边比它大的数的数量
            t[i]=sum(max)-sum(a[i]);   //求后边比它小的数的数量
            h[i]=sum(a[i]-1);
        }
        __int64 ans=0;
        for(i=1;i<=n;i++)
        {
            ans+=d[i]*h[i]+f[i]*t[i];
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值