poj 1011

Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 120261 Accepted: 27833

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

Source

Central Europe 1995

AC代码(代码解释):

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int a[70],n,len;
int vis[70];
int cmp(int k,int t){
    return k>t;
}
int dfs(int N,int s){
    if(N==0 && s==0)            //所有棍子都用完了则成功
        return 1;
    if(s==0)                    //棍子没用完,但已经匹配完一根了
        s=len;
    for(int i=0;i<n;i++){
        if(!vis[i] && a[i]<=s){
            if(i>0 && !vis[i-1] && a[i]==a[i-1])     //如果上一个棍子未使用,并和当前棍子长度相同,则不用
                continue;
            vis[i]=1;
            if(dfs(N-1,s-a[i]))
                return 1;
            else{
                vis[i]=0;
                if(a[i]==s || s==len) //s==len 这个的意思是假设原来的棍子长度为len下,却没有任何匹配成功,则说明当前len长度不是圆棍长度
                    return 0;         //没有这一个枝剪要超时的
            }
        }
    }
    return 0;
}
int main(){
    while(cin>>n && n){
        int i,sum=0;
        for(i=0;i<n;i++){
            cin>>a[i];
            sum+=a[i];
        }
        sort(a,a+n,cmp);
        for(i=a[0];i<=sum/2;i++){
            if(sum%i==0){
                len=i;
                memset(vis,0,sizeof(vis));
                if(dfs(n,len)){
                    cout<<len<<endl;
                    break;
                }
            }
        }
        if(i>sum/2)
            cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值