HDOJ 2846 Repository


Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5167    Accepted Submission(s): 1764


Problem Description

When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.

 


Input

There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.

 


Output

For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.

 


Sample Input

 
 
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s

 


Sample Output

  
  
0 20 11 11 2


#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<=(b);++i)
const int maxn = 26;
const int mod = 1e9+7;
const int INF = 1e9;
#define ll long long
#define rush() int T;scanf("%d",&T);while(T--)
struct Trie
{
    int id;
    int cnt;
    int next[maxn];
};
int ptr=0;
Trie word[1000001];
void Init(int z)
{
    for(int i=0; i<maxn; i++)
        {
            word[z].next[i]=-1;
            word[z].cnt=0;
        }
}
void Insert(char*s,int len,int x)
{
    int now=0;
    for(int i=0; i<len; i++)
    {
        int t=s[i]-'a';
        if(word[now].next[t]==-1)
        {
            word[now].next[t]=++ptr;
            Init(ptr);
            now=ptr;
        }
        else now=word[now].next[t];
        if(word[now].id!=x) //避免形如add造成的问题
        {
            word[now].cnt++;
            word[now].id=x;
        }
    }
}
int find(char*s)
{
    int now=0;
    int len=strlen(s);
    for(int i=0; i<len; i++)
    {
        int t=s[i]-'a';
        if(word[now].next[t]==-1)
            return 0;
        now=word[now].next[t];
    }
    return word[now].cnt;
}
int main()
{
    int n,m,len;
    char s[21];
    Init(0);
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",s);
        len=strlen(s);
        for(int i=0; i<len; i++)
            Insert(s+i,len-i,n+1);
    }
    scanf("%d",&m);
    while(m--)
    {
        scanf("%s",s);
        printf("%d\n",find(s));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值