HDOJ 1358 Period

Period

TimeLimit: 2000/1000 MS (Java/Others)    Memory Limit:65536/32768 K (Java/Others)
Total Submission(s): 8090    Accepted Submission(s): 3893

Problem Description

For each prefix of a given string S with N characters (each character has an ASCIIcode between 97 and 126, inclusive), we want to know whether the prefix is aperiodic string. That is, for each i (2 <= i <= N) we want to know thelargest K > 1 (if there is one) such that the prefix of S with length i canbe written as AK , that is A concatenated K times, for some stringA. Of course, we also want to know the period K.

 

 

Input

The input file consists of several test cases. Each test case consists of twolines. The first one contains N (2 <= N <= 1 000 000) – the size of thestring S. The second line contains the string S. The input file ends with aline, having the number zero on it.

 

 

Output

For each test case, output “Test case #” and the consecutive test case number on asingle line; then, for each prefix with length i that has a period K > 1,output the prefix size i and the period K separated by a single space; theprefix sizes must be in increasing order. Print a blank line after each testcase.

 

 

Sample Input

3

aaa

12

aabaabaabaab

0

 

 

Sample Output

Test case #1

2 2

3 3

 

Test case #2

2 2

6 2

9 3

12 4


KMP算法总结:传送门

题意:给出一个字符串,从第二个位置开始找到它前缀的最大重复次数及及此时的位置

思路:利用KMP的next数组求解。根据next数组的定义(当前位置的前缀后缀最大匹配长度),我们可以发现在位置i处如果出现了重复,必有i-next[i]为前缀最大的重复长度,此时满足(i%(i-next[i])==0),且重复的次数为(i/(i-next[i]))

#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<(b);++i)
typedef long long ll;
const int maxn= 1000005;
const int mod = 475;
const ll INF = 0x3f3f3f3f;
const double eps = 1e-6;
#define rush() int T;scanf("%d",&T);while(T--)
int n;
char s[maxn];
int nex[maxn];

void getnext()
{
    int i=0,j=-1;
    nex[0]=-1;
    while(i<n)
    {
        if(j==-1||s[i]==s[j])
            nex[++i]=++j;
        else j=nex[j];
    }
}

void KMP()
{
    getnext();
    for(int i=2;i<=n;i++)
    {
        int k=i-nex[i];
        if(i%k==0&&i/k>1)
        {
            printf("%d %d\n",i,i/k);
        }
    }
}

int main()
{
    int cas=1;
    while(~scanf("%d",&n)&&n)
    {
        scanf("%s",s);
        printf("Test case #%d\n",cas++);
        KMP();
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值