AS升级到3.+遇见滴问题

1:
Error:Unable to resolve dependency for ':app@debug/compileClasspath': Could not resolve com.android.support:appcompat-v7:26.1.0. Open File
Show Details
==大致意思就是依赖不上,一般都是网络原因,在File->Settings->Build, Execution, Deployment->Gradle->目录下把Offline work离线工作的选项关掉重新编译就ok了 .

2:
同样还是依赖问题
网上给的大致意思是因为AS版本问题,

即:module A implementation libA,而 moduleB implementation module A,那么module B 引导 libA 中的api,不然在build的时候会报org.gradle.api.internal.tasks.compile.CompilationFailedException

  • 解决办法:将compile 替换为 api即可,也就是如果有外部引用,则换成:api,剩下的换成:implementation。

示例:

dependencies {
    api fileTree(dir: 'libs', include: ['*.jar'])
    testImplementation 'junit:junit:4.12'
    api 'com.android.support:support-v4:26.1.0'
    api 'com.android.support:appcompat-v7:26.1.0'

    api 'com.google.code.gson:gson:2.8.2'

    api 'com.j256.ormlite:ormlite-core:4.48'
    api 'com.j256.ormlite:ormlite-android:4.48'
没有采用,因为我改了依赖方式同事就会报错 我的是3.1.1 同事的是3.0.1他加的依赖在我这边报的错所以我又装了个3.0.1版本的重新编译 ok了
阅读更多
个人分类: android
想对作者说点什么? 我来说一句

安装2010出现的问题解决

2014年02月18日 25KB 下载

没有更多推荐了,返回首页

不良信息举报

AS升级到3.+遇见滴问题

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭