Attribute Parser

内容:


说明:

通过输入的xml信息,查找对应的值

示例代码:

// Attribute_Parser.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"
#include <map>
#include <sstream>
#include <iostream>
using namespace std;

/*
sample input
4 3
<tag1 value = "HelloWorld" >
<tag2 name = "Name1">
< / tag2>
< / tag1>
tag1.tag2~name
tag1~name
tag1~value
-----------------------------
sample output
Name1
Not Found!
HelloWorld
*/

//by rwan7727
int main()
{
    int n, q;
    cin >> n >> q;
    cin.ignore();

    map <string, string> attributeDB; // to store attribute-value pairs
    string inputstr, tag_preamble = "";

    // get each HRML line
    for( int i = 0; i < n; i++ )
    {
        getline( cin, inputstr );

        // for each HRML line, break it up
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值