NOI openjudge 8436:Saving Tang Monk

8436:Saving Tang Monk


描述

《Journey to theWest》(also 《Monkey》) is one of the Four Great Classical Novelsof Chinese literature. It was writtenby Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong,pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to getsacred Buddhism texts.

During thejourney, Tang Monk was often captured by demons. Most of demons wanted to eatTang Monk to achieve immortality, but some female demons just wanted to marryhim because he was handsome. So, fighting demons and saving Monk Tang is themajor job for Sun Wukong to do.

Once, TangMonk was captured by the demon White Bones. White Bones lived in a palace andshe cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. Butto rescue Tang Monk, Sun Wukong might need to get some keys and kill somesnakes in his way.

The palace can be described as a matrix of characters. Each characterstands for a room. In the matrix, 'K' represents the original position of SunWukong, 'T' represents the location of Tang Monk and 'S' stands for a room witha snakein it. Please note that there are only one 'K' and one 'T', and at mostfive snakesin the palace. And, '.' means a clear room as well '#' means a deadlyroom which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, butthere is at most one key in one room. There are at most 9 kinds of keys. A roomwith a key in it is represented by a digit(from '1' to '9'). For example, '1'means a room with a first kind key, '2' means a room with a second kind key,'3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukongmust get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong couldmove to the adjacent rooms(except deadly rooms) in 4 directions(north, west, southand east), and each step took him one minute. If he entered a room in which aliving snakestayed, he must kill the snake.Killing a snakealso took one minute. If Sun Wukong entered a room where there is a keyof kind N, Sun would get that key if and only if he had already got keys ofkind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key ofkind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got allkeys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys,he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey,he wanted to save Tang Monk as quickly as possible. Please figure out theminimum time Sun Wukong needed to rescue Tang Monk.


输入
There are several test cases.
For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M). 
Then the N×N matrix follows.
The input ends with N = 0 and M = 0.
输出
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
样例输入
3 1
K.S
##1
1#T
3 1
K#T
.S#
1#.
3 2
K#T
.S.
21.
0 0
样例输出
5
impossible
8
 
  
BFS+状态压缩 注意细节 
用优先队列维护,因为父亲扩展到儿子,不再是等价的,第二判重加快效率
#include<iostream>  
#include<cstdio>  
#include<functional>  
#include<queue>  
#include<vector>  
#include<cstring> 
using namespace std;
const int N=105,M=11;

char mp[N][N];
char seid[N][N];
int m,n;

struct node{
	int x,y,step, key;
	unsigned long long s;
	node(){x=y=step=s=key=0;}
	bool operator > (const node & b) const{
	return step> b.step;
	}
}st,target;

int dx[]={1,-1,0,0},dy[]={0,0,1,-1};
bool vis[N][N][M];

void readdata(){	
	int tot=0;
	for(int i=0;i<n;++i){
	  for(int j=0;j<n;++j)	{
	 	cin>>mp[i][j]; 
		 if(mp[i][j]=='K')st.x=i,st.y=j;
		 else if(mp[i][j]=='T')target.x=i,target.y=j;	
		 else if(mp[i][j]=='S')seid[i][j]=tot++;
	 	} 
	}
}
node expand(node cs,int i){
	cs.x+=dx[i],cs.y+=dy[i],cs.step+=1;	
	if(mp[cs.x][cs.y]=='S' ) {
		if((cs.s & (1<<seid[cs.x][cs.y]))==0){
			cs.s|=1<<seid[cs.x][cs.y];
			cs.step+=1;
		}  
	}
	if(mp[cs.x][cs.y]==cs.key+'1')cs.key+=1;	
	return cs;
}

bool check(node cs,int nx,int ny){
	if(nx<0 || nx>=n || ny<0 || ny>=n || mp[nx][ny]=='#')return false;		
	int nkey=cs.key;
	if(mp[nx][ny]==cs.key+'1')nkey=cs.key+1;
	if(vis[nx][ny][nkey])return false;
	return true;
}
bool ckmb(node cs,node target){
	if(cs.x!=target.x||cs.y!=target.y)return false ;
    if(cs.key<m)return false ;
	return true;
}


void bfs(){
	priority_queue< node, vector<node>, greater<node>  > q;
	bool ok=false;
	q.push(st);
	while(!q.empty()){
		node cs=q.top();q.pop();
		if(ckmb(cs,target)) {printf("%d\n",cs.step);ok=true;break;}
		else 
		for(int i=0;i<4;i++){
		int nx=cs.x+dx[i],ny=cs.y+dy[i];
		if(check(cs,nx,ny)){
		node ns=expand(cs,i);
		vis[nx][ny][ns.key]=1;
		q.push(ns);
		}
		}
	}
	if(!ok)printf("impossible\n");
}

int main(){
		
while(scanf("%d%d",&n,&m)!=EOF){
if(m==0&& n==0)break;
memset(vis,0,sizeof vis);
memset(seid,0,sizeof seid);
readdata();
bfs();
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值