Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
输入样例:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
输出样例:
YES
NO
NO
YES
NO
#include<stdio.h>
int stack[1001]; //状态标记 0表示未出栈 1表示已经出栈
int judge(int m,int n)
{
int i,j,temp;
int a[n];
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
stack[a[i]]=0; //初始化问出栈
}
for(i=0;i<n-1;)
{
//处于递增序列时相当于直接出栈
while(i<n-1&&a[i]<a[i+1])
{
stack[a[i]]=1;
i++;
}
//处于递减序列说明前面积累了一些数字小且没有出栈的
temp=1;//记录当前栈长,不能超标
while(i<n-1&&a[i]>a[i+1])
{
for(j=a[i]-1;j>a[i+1];j--)
if(stack[j]==0)
return 0; //还有未出栈的但跳过了比如 如果2没出栈 则3后面不能出1
temp++;
if(temp>m)
return 0;
stack[a[i++]]=1;
}
}
return 1;
}
int main()
{
int N,M,K;
int i,j;
scanf("%d %d %d",&M,&N,&K);
int a[K];//这个是来存输出结果的
for(i=0;i<K;i++)
a[i]=judge(M,N);
for(i=0;i<K-1;i++)
{
if(a[i]==0)
printf("NO\n");
else printf("YES\n");
}
if(a[i]==0)
printf("NO");
else printf("YES");
return 0;
}