1044 Shopping in Mars (25 分)

36 篇文章 1 订阅

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N ( ≤ 1 0 5 ≤10^5 105), the total number of diamonds on the chain, and M ( ≤ 1 0 8 ≤10^8 108), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯D**N (D**i 1 0 3 10^3 103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of ij such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of ij such that Di + … + Dj >M with (Di + … + DjM) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
结尾无空行

Sample Output 1:

1-5
4-6
7-8
11-11
结尾无空行

Sample Input 2:

5 13
2 4 5 7 9
结尾无空行

Sample Output 2:

2-4
4-5
结尾无空行

解释:

输入N,S

接下来输入N个数字作为序列

在这个序列中找到连续的子序列,使他的和等于S,以i-j的格式输出,多个子序列按i递增的方式输出

如果没有等于S的序列,就输出子序列和大于S但是又相差最少的 按i递增的顺序输出i-j

#include<cstdio>
#include<algorithm>
using namespace std;
int sum[100010];
int nearS=100000010;
//long long pre[100010];
//long long num[100010];
int main()
{
    int N,S;
    scanf("%d %d",&N,&S);
    sum[0]=0;
    //计算前缀和,前缀和是一个递增的序列
    for(int i=1;i<=N;i++)
    {
        scanf("%d",&sum[i]);
        sum[i]+=sum[i-1];
    }
    //找到有没有和是S的子序列
    for(int i=1;i<=N;i++)
    {
        //二分查找第一个大于sum[i-1]+S的数字位置
        int j=upper_bound(sum+i,sum+N+1,sum[i-1]+S)-sum;
        //这子序列后退一个数,即sum[j-1]-sum[i-1]==S 
        //存在这一的子序列,记录一下,break
        if(sum[j-1]-sum[i-1]==S)
        {
            nearS=S;
            break;
        }//找到比S稍微大一些的序列和
        else if(j<=N&&sum[j]-sum[i-1]<nearS)
            //遍历完,一直找,找到最小的大于S的序列和
            nearS=sum[j]-sum[i-1];
    }
    for(int i=1;i<=N;i++)
    {
        //二分查找第一个大于sum[i-1]+S的数字位置
        int j=upper_bound(sum+i,sum+N+1,sum[i-1]+nearS)-sum;
        //没有这个判断不行,因为多加了一个num[j]才满足大于,减去num[j]不一定等于nearS
        if(sum[j-1]-sum[i-1]==nearS)
            printf("%d-%d\n",i,j-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值