poj 1258 Agri-Net【Kruskal】


Agri-Net

题目大意:先输入一个数n,


Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

看到网上都是用prim写得,用Kruskal写得比较少,所以就决定用Kruskal写了

#include <cstdio>
#include <algorithm>
using namespace std;
int n;
int pre[101];
struct ak{
	int x, y, dis;
}rela[10000];

void init() {
	for(int i = 0; i < n; i++)
		pre[i] = i;
}

int cmp(ak c, ak e) {
	return c.dis < e.dis;
}

int find(int x) {
	int r = x;
	while(r != pre[r])
		r = pre[r];
	int i = x, j;
	while(i != r) {
		j =pre[i];
		pre[i] = r;
		i = j;
	}
	return r;
}

bool join(int x, int y) {
	int fx = find(x);
	int fy = find(y);
	if(fx != fy) {
		pre[fx] = fy;
		return true;
	}
	return false;
}

int Scanf_a() {
	int a, q = 0, total = 0;
	for(int i = 0; i < n; i++)
		for(int j = 0; j < n; j++) {
			scanf("%d", &a);
			if(i != j) {
				rela[q].x = i;
				rela[q].y = j;
				rela[q++].dis = a;
			}
		}
	init();
	sort(rela, rela + q, cmp);
	for(int i = 0; i < q; i++) {
		if(join(rela[i].x, rela[i].y))
			total += rela[i].dis;
	}
	return total;
}

void Printf_a(int total) {
	printf("%d\n", total);
}

int main() {
	while(scanf("%d", &n) !=EOF) {
		Printf_a(Scanf_a());
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值