Fliptile——二进制枚举

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.
As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.Input
Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0
思路见
题解
这里对原来的代码做一点注释,方便理解

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
const int MAXN = 20;
using namespace std;
int ma[MAXN][MAXN];//原地图
int tmp[MAXN][MAXN];//判断一个点是否进行翻转
int now[MAXN][MAXN];//输出的地图
int m,n;
int dir[5][2] = {{0,0},{0,-1},{-1,0},{0,1},{1,0}};//方向数组
int ask(int x,int y){//判断该点是否为1
	int t = ma[x][y];
	for(int i=0;i<5;i++)
	{
		int tx = x+dir[i][0];
		int ty = y+dir[i][1];
		t += tmp[tx][ty];
	} 
	return t%2;
}
int solve(){
	for(int i=2;i<=m;i++)
		for(int j=1;j<=n;j++)
		{
			if(ask(i-1,j)==1){//如果上一行是1
				tmp[i][j] = 1;
			}
		}
	for(int i=1;i<=n;i++)//如果到最后一行有点为1,那么不可能
	{
		if(ask(m,i)) return -1;
	}
	int ans = 0;//需要翻转的点
	for(int i=1;i<=m;i++)
		for(int j=1;j<=n;j++)
		{
			if(tmp[i][j]) ans++;
		}
	
	return ans;
}
int main(){
	cin>>m>>n;
	int minn = -1;
	for(int i=1;i<=m;i++)
	{
		for(int j=1;j<=n;j++)
		{
			cin>>ma[i][j];
		}
	}
	for(int i=0;i<(1<<n);i++)//第一行进行枚举
	{
		memset(tmp,0,sizeof tmp);
		for(int j=1;j<=n;j++)
           	tmp[1][j] = (i >> (j - 1)) & 1;
	        int num = solve();
	        if(num!=-1&& (minn<0||minn>num) )
	        {
	            minn = num;
	//          cout<<minn<<endl;
	            memcpy(now, tmp, sizeof(tmp));/*把tmp里面所有的元素,全部复制到print里面去*/
	        }
	}
	//输出结果
	if(minn==-1) cout<<"IMPOSSIBLE"<<endl;
	else
	for(int i=1;i<=m;i++)
	{
		for(int j=1;j<=n;j++)
		{
			cout<<now[i][j]<<" ";
		}
		cout<<endl;
	}
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值