pat 1013. Battle Over Cities (25)

1013. Battle Over Cities (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

提交代码

评测结果

时间 结果 得分 题目 语言 用时(ms) 内存(kB) 用户
7月29日 16:17 答案正确 25 1013 C++ (g++) 123 8064 jack

测试点

测试点 结果 用时(ms) 内存(kB) 得分/满分
0 答案正确 1 380 7/7
1 答案正确 1 384 8/8
2 答案正确 7 504 3/3
3 答案正确 12 4224 3/3
4 答案正确 123 8064 4/4
查看代码

最开始让某个点访问过,然后用bfs进行遍历,遍历过多少次,就有多少个分块。如果分块大于等于2,那么公路最少只需要m-1.如果分块只有
0或者1,那么就不需要公路了。
// 16:01 reading 经过不断的练习,以前做不出来的题目,现在应该可以做出来了,我们
//拭目以待-> 16:18果然,我不断的使用bfs结果真的让我一次性通过了,而且而是分钟就
//写完了,哈哈
#include <stdio.h>
#include <queue>
using namespace std;

int graph[1003][1003];
int visit[1003];
int countPartition(int n);
int main()
{
  int n,m,k;
  int x,y,con;
  scanf("%d%d%d",&n,&m,&k);
  for(int i=0;i<m;i++)
  {
    scanf("%d%d",&x,&y);
    graph[x][y] = 1;
    graph[y][x] = 1;
  }
  for(int i=0;i<k;i++)
  {
    scanf("%d",&con);
    visit[con] = 1;
    int res = countPartition(n);
    if(res>1)
    {
      printf("%d\n",res-1);
    }else
    {
      printf("0\n");
    }
    for(int j=0;j<=n;j++)
    {
      visit[j] = 0;
    }
  }
  return 0;
}
int countPartition(int n)
{
  int count = 0,next;
  for(int i=1;i<=n;i++)
  {
    if(!visit[i])
    {
      visit[i] = 1;
      queue<int> que;
      que.push(i);
      while(que.size()>0)
      {
        next = que.front();
        que.pop();
        for(int j=1;j<=n;j++)
        {
          if(!visit[j]&&graph[next][j]==1)
          {
            visit[j] = 1;
            que.push(j);
          }
        }
      }
      count++;
    }
  }
  return count;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值