ACM暑期集训 同余定理+逆元 练习题 一个大数对一个数取余

ppt内容

大数取模
一个大数对一个数取余,可以把大数看成各位数的权值与个
位数乘积的和。
比如1234 = ((1 * 10 + 2) * 10 + 3) * 10 + 4,对这个数进
行取余运算就是上面基本加和乘的应用。
代码实现
int len = a.length();
int ans = 0;
for(int i = 0; i < len; i++){
ans = (ans * 10 + a[i] - ’0’) mod b;
}

E - Integer Divisibility

 

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit (1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

题意:给定两个数n,d,d是一位数字,问最小的能整除n且只含数字d的数是几位数。

思路:从后先前分析:随意给定一个只含d的数,这个数可以分为两部分的和:一部分是能被n整除的,另一部分对n的余数。如果这个数不能被n整除,那么这个数就要再多一位了,就等于把现在的数*10+d,现在能被n整除的部分乘10以后依然能被n整除,那么我们就只需考虑现余数的部分了,只要现在余数的部分乘以10+d能被n整除就找到了这个数

代码:

#include <stdio.h>
typedef long long ll;//要用long long型 
int main()
{
	ll t,k=0;
	scanf("%lld",&t);
	while(t--)
	{
		ll n,d,z=1,i;//z初值等于1 
		k++;
		scanf("%lld%lld",&n,&d);
		ll r=d;
		while(r%n)
		{
			z++;
			r=r%n*10+d;//改变的是r,d是一个定值 
		}
		printf("Case %lld: %lld\n",k,z); 
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值