算术基本定理+容斥-17级暑假集训

G - Ekka Dokka

 https://vjudge.net/contest/240973#problem/G

基础题水题:

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

题意:
t组
对于每一组,给出w(2<=w<=2^63),
问是否存在正数n,m,n奇m偶,满足n*m=w,没有输出...
若有输出n,m,若有多组则输出让m尽可能小的那一组

有一点没有注意:奇数*偶数=偶数,所以奇数一定不可能

偶数一定可以(可分解成1乘本身)

代码:

#include <stdio.h>
#include <math.h>
typedef long long ll;
int main()
{
	ll t,w,k=0,i;
	scanf("%lld",&t);
	while(t--)
	{
		k++;
		scanf("%lld",&w);
		if(w%2!=0)//奇数时一定不存在 
			printf("Case %d: Impossible\n",k);
		else
		{
		for(i=2;i<=w;i=i+2)
		{
			if(w%i==0)
			{
				if((w/i)%2!=0)
				{
				printf("Case %d: %lld %ld\n",k,w/i,i);
				break;
			    }
			}
		}
	    }
	}
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值