1000

1000

Problem Description Calculate A + B.

Input Each line will contain two integers A and B. Process to end of file.

Output For each case, output A + B in one line.

Sample Input 1 1
Sample Output 2

要点:
1.计算不是一次性的,需要满足连续输入的要求,如下
1 2
3
3 4
7
因此需要循环,可用while
2.要求的输入只有数字,当output输出之后需要自行跳转到下一个input,可以用\n©
或endl;
3.Process to end of file. 处理到文件的结束

c语言

#include<stdio.h>
int main()
{
 int a,b;
 while(~scanf("%d%d",&a,&b))
 {
  printf("%d\n",a+b);                               //  \n 本句结束
 }
}


c++语言
#include<iostream>
using namespace std;
int main()
{ 
    int i,j;
    while(cin>>i>>j) 
    {
        cout<<i+j<<endl;                          // endl 本句结束
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值