Rightmost Digit

Given a positive integer N, you should output the most right digit of N^N. 
InputThe input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
OutputFor each test case, you should output the rightmost digit of N^N. 
Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

by talk:最近刚刚学的快速幂,此题和快速幂差不多,快速幂是求a^b,这道题是求n^n的最右边的一位数字,那么取个模就ok啦。

#include<stdio.h> 
long long digital(long long a,long long b) 
{     
        long long ans=1;     
        while(b)    
       {         
           if(b&1)             
          ans=(ans*a)%10;         
          a=(a*a)%10;         
          b>>=1;     
      }     
   return ans; 
} 
int main() 
{     
     long long n,m;     
     scanf("%I64d",&n);     
     while(n--)     
    {         
          scanf("%I64d",&m);         
          printf("%I64d\n",digital(m,m));     
    }     
  return 0; 
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值