1000注意EOF,1001、1002题大数的相加

1000
Calculate A + B.

Input
Each line will contain two integers A and B. Process to end of file.

Output
For each case, output A + B in one line.

Sample Input
1 1

Sample Output
2

*#include<stdio.h>
int main(){
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
	printf("%d\n",a+b);
	return 0;
}**

注:Process to end of file.所以要用while(!=EOF) EOF end of file

1001
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

代码如下
如果按照正常的求和

1002

运用普通的方法求和完全能够成功

#include<stdio.h>
int main(){
int n,i,sum;
//sum=0;
while(scanf("%d",&n)!=EOF)
{		
		sum=0;
for(i=0;i<=n;i++)
	sum+=i;
printf("%d\n\n",sum);
}

return 0;
}

运用代数求和的方法要小心溢出,这就是后面那个You may assume the result will be in the range of 32-bit signed integer.**所提示。
代码如下

#include<stdio.h>
int   main(){
	   int  n,sum;
	while(scanf("%d",&n)!=EOF)
	{		
		if(n%2==0)
			sum=n/2*(n+1);
		else
			sum=(n+1)/2*n;
	printf("%d\n\n",sum);
	}

	return 0;
}

1002

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


#include<stdio.h>
#include<string.h> 

int main()
{
  int i,n;//定义一个需要输入循环加法的次数
  scanf("%d",&n);//输入该次数
  for(i=1;i<=n;i++)//开始循环
  {
  	char s1[1001],s2[1001];//把数据存储在字符串数组中
	int a[1001]={0},b[1001]={0},c[1001]={0};//int型数组 
	int len1,len2,len3;//保存字符串的长度
	int max;//得到最大长度字符串
	int q,k;//字符串转化为int型数组变量
	int m,d;//数组相加的数组变量
	int l;
	scanf("%s%s",s1,s2);
	len1=strlen(s1);
	len2=strlen(s2);//输入字符串,获得字符串的长度
	if(len1>len2)
	{
		max=len1; 
	 } 
	 else
	 {
	 	max=len2;
	}
		 //如果len1大于len2,最大长度字符串为len1 
		for(q=0,k=len1-1;q<len1;q++,k--)//字符串末尾数据放到了int数组的开头 
		{
			a[q]=s1[k]-48; 
		 } 
		 for(q=0,k=len2-1;q<len2;q++,k--)//字符串末尾数据放到了int数组的开头 
		{
			b[q]=s2[k]-48; 
		 } 
		 //把字符串型转化为int型
		 
		 for(d=0,m=0;m<max;m++)
		 {
		 	c[m]=(a[m]+b[m]+d)%10;
		 	d=(a[m]+b[m]+d)/10;
		  } 
		  printf("Case %d:\n%s + %s = ",i,s1,s2);
		  if(d!=0)
		  {
		   c[max]=1;
		  for(len3=max;len3>=0;len3--)
		  {
		    printf("%d",c[len3]); 
		  }
		  
		  }
	 else
	 {
	 	for(len3=max-1;len3>=0;len3--)
	 	{
		 printf("%d",c[len3]);
		 }
	 }
	 if(i!=n)
	 {
	 	printf("\n\n");
	 }
	 else
	 {
	 	printf("\n");
	 }
	
	 
   } 
   return 0;
}

1090

Problem Description
Your task is to Calculate a + b.

Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
2
1 5
10 20

Sample Output
6
30

代码如下

#include<stdio.h>
#include<string.h>
#define m 1000
int main(){
	int a,b,n,j[m],i;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{	
		scanf("%d%d",&a,&b);
		j[i]=a+b;
	}
	//从0开始读取每一个数值
	i=0;
	while(i<n)
	{
			printf("%d",j[i]);
			i++;
			printf("\n");
	}
	return 0;
}

以数组的形式存储每一个结果的值

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值