Freckles

Description

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through.
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

Input

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

 

Sample Output

3.41
题目大概意思是所有点能通过直线连起来,求最小的长度(题目我没看懂,是别人帮我讲的)
题目的典型的最小生成树,方法有多种,我学的是prim算法吧。
建立两个集合u{} v{},u{}里放的是未放进V{}的,v{}放的是已经生成树的结点,
当所有的点都几经在V{}时最小生成树已经形成;
核心思想是prim算法;
我的代码如下:
#include<iostream>
#include<string.h>
#include <cmath>
using namespace std;
int main()
{
 int n,i,j,tag,count,k;
 int v[101],u[101];
 double x[101],y[101],min[101],d,mi,sum;
 while( cin >> n )
 {
  sum = 0;
  for( i = 1; i <= n; i ++ )
  {
   cin >> x[i] >> y[i];
   v[i] = 0;
   u[i] = 1;
  }   
  v[1] = 1;
  u[1] = 0;
  count = 1;
  while( count != n )
  {
   mi = 99999999;
   for( i = 2; i <= n; i ++ )//位放进集合V的进行一次次放进去;
   { 
    if( u[i] == 1 )
    {
     min[i] = 99999999;
     for( j = 1; j <= n; j ++)//几经放进集合V的;
      if( v[j] == 1 )
      {
       d = sqrt( ( x[i] - x[j] )*( x[i] - x[j] ) + ( y[i] - y[j] )*( y[i] - y[j] ) ) ;
       if( min[i] > d ) { min[i] = d; }//与集合V{}里中的点最短的距离记为自己的进入v{}的最小距离;
      }
    }
   }
   for( k = 1; k <= n; k ++ )
    if( u[k] == 1 )
     if( mi > min[k] )
     {
      mi = min[k]; tag=k;//从未加入u{}的点里面选出最小能加进数里的点。并记下来;
     }
     v[tag] = 1;
     u[tag] = 0;//把选好的最优点加进来。
     sum+=mi;
     count ++;
  }
  printf( "%.2lf/n",sum);
 }
 return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值