hdu 3367 Pseudoforest

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 87    Accepted Submission(s): 21

Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

 

Sample Input
  
  
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
 

 

Sample Output
  
  
3 5
 

 

Source
不多分析,只贴大牛详解题意分析!
在这里支持下那位大牛的观点,WHU的题意太不明确啊!!!
#include<iostream>
using namespace std;
#define M 100005
#define N 10005
struct node
{
 int x,y;
 int len;
}g[M];
int cmp(const void *a,const void *b)
{
 return (*(node *)b).len - (*(node *)a).len;
}
int father[M],n;
int cha(int x)
{
    if(x==father[x])
        return x;
    father[x]=cha(father[x]);
    return father[x];
}
int bing(int x,int y)
{
    father[cha(x)]=cha(y);
    return 0;
}
int main()
{
    int k,x,y,z,m,i,ans;
    int used[N];
 while(scanf("%d%d",&n,&m)&&(m||n))
    {
        for(i=0;i<m;i++)
        {
   scanf("%d%d%d",&g[i].x,&g[i].y,&g[i].len);
        }
        for(i=0;i<=n;i++)
            father[i]=i;
        k=0;
      //  int max=0;
        ans=0;
        qsort(g,m,sizeof(g[0]),cmp);
  memset(used,0,sizeof(used));
        for(i=0;i<m;i++)
        {
   x=g[i].x;
   y=g[i].y;
            z=g[i].len;
   int ca=cha(x);
   int cb=cha(y);
            if(ca!=cb)
            {
    if(used[ca]==0 || used[cb] ==0)
    {
     ans+=z;
     if(used[cb] == 1)
      bing(x,y);
     else
      bing(y,x);
    }
            }
   else if(used[ca]==0)
   {
    used[ca] = 1;
    ans+=z;
   }
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值