uvaoj-489:刽子手

原题:

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.
       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.

题意:

         给定两个字符串,第一个串是用来匹配的,从第二个串的第一个字符开始匹配,如果第二个串中的字符在第一个串出现,则表示猜中了,第一个串中的相同的那个字符都算被猜中;如果没有出现则表示猜错,同样的猜错只算一次。在整个匹配的过程中,如果在还没猜错7次之前,第一个串中所有的字符都被猜完了, 则输出“You win.”,如果你还没全部猜完的时候就已经猜错7次,则输出“You lose.”。如果整个匹配过程结束后,你没赢也没输,则输出“You chickened out.”。(引自acboy的博客)


题解:刘汝佳白书79页的例题,下边的解法基本和书上的相同,想看别的解法的请参考别的大神的code,基本就是纯粹的模拟,但值得一提的是利用了全局变量,因为在主函数和自定义函数里用的是相互有关联的变量;


code:

#include <iostream>
#include <cstdio>
#include <cstring>
#define maxn 105//宏定义
using namespace std;

char s[maxn],ans[maxn];
int win,lose,chance,lef;//定义全局变量(left与c++库函数相同,尽量避免定义相同的名称);

void guess(char c);//声明函数;
int main()
{
    int n;
    while(~scanf("%d%s%s",&n,s,ans)&&(n!=-1))
    {

        printf("Round %d\n",n);
        win=lose=0;//初始化判断结果的变量;
        int lenans=strlen(ans);
        chance=7;//初始化代表机会次数的变量;
        lef=strlen(s);//在这里取字符串s的长度来表示剩余字符的量;
        for(int i=0; i<lenans; i++)
        {
            guess(ans[i]);
            if(lose||win) break;//达到条件以后就可以跳出;
        }
        if(win) puts("You win.");
        else if(lose) puts("You lose.");
        else  puts("You chickened out.");
    }
    return 0;
}
void guess(char c)
{
    int lens=strlen(s);
    bool flag=0;
    for(int i=0; i<lens; i++)
    {
        if(s[i]==c)
        {
            lef--;
            s[i]==' ';//将s[i]变为空格避免下次有相同字符进行判定的时候会发生误判现象;
            flag=1;
        }
    }
    if(flag==0) --chance;//注意不要将这些语句不小心放进循环里;
        if(chance==0)
        {
            lose=1;
        }
        if(lef==0)
        {
            win=1;
        }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值