uvaoj-540:team queue

(小白详细讲解向)//

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.



In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.



Your task is to write a program that simulates such a team queue.

Input
The input file will contain one or more test cases. Each test case begins with the number of teams t ( ). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case

The input will be terminated by a value of 0 for t.



Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output
For each test case, first print a line saying ``Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001


题解:首先奉上从别人博客里面找到的流程图:


这道题是刘汝佳白书118页例题5-6;题目考察的就是对queue知识和少量map知识的理解和运用;

思路就是列多个列队:

首先是主列队q,主列队里面存放的是分列队的编号,也可以理解为指向不同分列队的指针:因为不同的元素属于不同的团队,每一个团队的元素在一起构成一个分列队;这样方便判断分列队是否为空,以及对分列队进行处理;

其次是分列队qq[maxn],分列队的数目不大于1000,所以使的maxn为1010,分列队里面存放的是具体的元素,也就是成员;

进行插入的时候首先判断分列队是否为空,为空的话就先在主列队里面插入一个指向该分列队的指针,否则只需在分列队里面插入元素即可;

进行出队操作的时候首先提取出主列队里面最前面的指针,在根据指针提取出分列队,将分列队里面的第一个元素pop并打印,在判断分列队是否为空,为空则删除指针;

具体代码如下:


code:-2

#include <iostream>
#include <cstdio>
#include <string>
#include <map>
#include <queue>
using namespace std;
int main()
{
    int n;
    int kase=0;
    while(cin>>n&&n)
    {
        printf("Scenario #%d\n",++kase);

        //
        map<int,int> m;
        for(int i=0; i<n; i++)
        {
            int c;
            cin>>c;
            int x;
            while(c--)
            {
                cin>>x;
                m[x]=i;
            }
        }

        //
        string order;
        queue<int> q,qq[1010];
        while(1)
        {
            cin>>order;
            if(order[0]=='S') break;

            else if(order[0]=='E')
            {
                int x;
                cin>>x;
                int t=m[x];
                if(qq[t].empty())
                q.push(t);
                qq[t].push(x);
            }

            else if(order[0]=='D')
            {
                int t=q.front();
                cout<<qq[t].front()<<endl;;
                qq[t].pop();
                if(qq[t].empty())
                q.pop();
            }
        }
        cout<<endl;
    }
    return 0;
}


笔记:
queue常用函数:
queue<int> q;
q.pop();
q.push(x);
x=q.front();
x=q.back();
q.empty();

stack和queue主要区别就是出进的区别,stack后进先出,queue先进先出;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值