A:最大公约数和最小公倍数
Description
请计算2个数的最大公约数和最小公倍数;(最大公约数可以使用辗转相除法,最小公倍数=2个数的乘积/它们的最大公约数;)
Input
输入数据有多组,每组2个正整数a,b(2<a,b<1000)
Output
在一行内输出a和b的最大公约数和最小公倍数;
Sample Input
15 10
Sample Output
5 30
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int gcd(int x,int y)
{
return y?gcd(y,x%y):x;
}
int lcm(int x,int y)
{
return x/gcd(x,y)*y;
}
int main()
{
int a,b,ans1,ans2;
int gcd(int x,int y);
while(cin>>a>>b)
{
ans1=gcd(a,b);
ans2=lcm(a,b);
cout<<ans1<<" "<<ans2<<endl;
}
return 0;
}
B:又见GCD
Description
有三个正整数a,b,c(0<a,b,c<106),其中c不等于b。若a和c的最大公约数为b,现已知a和b,求满足条件的最小的c。
Input
每行输入两个正整数a,b。
Output
输出对应的c,每组测试数据占一行
Sample Input
6 2
12 4
Sample Output
4
8
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int gcd(int x,int y)
{
return y?gcd(y,x%y):x;
}
int main()
{
int a,b,c,i;
while(cin>>a>>b)
{
for(i=2;;i++)
if(gcd(a,i*b)==b)break;
c=i*b;
cout<<c<<endl;
}
return 0;
}
C: 多个数的最大公约数
Description
给定n(n<=10)个正整数,你的任务就是求它们的最大公约数,所有数据的范围均在long long内。
Input
输入数据有多组,每组2行,第一行为n,表示要输入数字的个数,接下来第二行有n个正整数。
Output
输出一个数,即这n个数的最大公约数。
Sample Input
5
2 4 6 8 10
2
13 26
Sample Output
2
13
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
long long gcd(long long x,long long y)
{
return y?gcd(y,x%y):x;
}
int main()
{
int n,i;
long long a