hdu5050 Divided Land

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5050

Divided Land

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 179    Accepted Submission(s): 98


Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
 

Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 2 1000)
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.
 

Sample Input
  
  
3 10 100 100 110 10010 1100
 

Sample Output
  
  
Case #1: 10 Case #2: 10 Case #3: 110
 

Source

水题啊,java不太会坑了好久,就是求最大公约数就行,就当学习java了。

BigIntger m = new BigInteger(st, base); // st是字符串,base是st的进制.

m.toString(base)  //把大数m转换成base进制

import java.util.*;
import java.math.*;
public class Main {

	/**
	 * @param neko01
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner cin=new Scanner(System.in);
		int t=cin.nextInt();
		for(int i=1;i<=t;i++)
		{
			String stra=cin.next();
			String strb=cin.next();
			BigInteger a=new BigInteger(stra,2);
			BigInteger b=new BigInteger(strb,2);
			BigInteger ans=a.gcd(b);
			System.out.println("Case #"+i+": "+ans.toString(2)); //转换成二进制输出
		}
		cin.close();
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值