水仙花数
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 62703 Accepted Submission(s): 18381
Problem Description
春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的:
“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=1^3+5^3+3^3。
现在要求输出所有在m和n范围内的水仙花数。
Input
输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。
Output
对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。
Sample Input
100 120
300 380
Sample Output
no
370 371
#include <ctype.h>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char f(int n){
int r = 0, nr = n, t;
while ( n > 0 ){
t = n%10;
r += t*t*t;
n /= 10;
}
return r == nr;
}
int main(){
char b;
int x, y, i;
while ( ~scanf("%d%d", &x, &y) ){
b = 0;
for ( i=x; i<=y; ++i ){
if ( f(i) ){
if ( b ){
printf(" ");
}
b = 1;
printf("%d", i);
}
}
if ( b == 0 ){
printf("no");
}
printf("\n");
}
return 0;
}