poj 3641 Pseudoprime numbers

Pseudoprime numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8673 Accepted: 3640

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes
题意:给出两个数p,a 如果p不是合数输出no 否则判断a的p次方对p取模之后是不是等于a
#include<stdio.h>
__int64 a,p;
__int64 quickpow(__int64 x,__int64 y,__int64 m)
{
	__int64 ans = 1;
	while(y)
	{
		if(y&1)
		{
			ans=(x * ans) % m;
		}
		x = (x * x ) % m;
		y >>= 1;
	}
	return ans;
}
bool prime(__int64 n)
{ 
    if((n > 2 && n % 2 == 0) || (n == 1))  
        return false;  
    bool flag=true;  
    for(int i = 3;i * i <= n;i += 2)  
    {  
        if(n % i == 0)  
        {  
            flag = false;  
            break; 
        }  
    }  
    return flag;		  
}
int main()
{
	while(~scanf("%I64d%I64d",&p,&a))
	{
		if( p == 0 && a == 0)
		   break;  
	    if(!prime(p))
		{
			if( quickpow(a,p,p) == a )
			   printf("yes\n");
			else
			   printf("no\n"); 
		}   	 
		else
		     printf("no\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值