hdu 1387 Team Queue(队列)

Team Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2020    Accepted Submission(s): 701


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue. 

 

Input
The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 

Finally, a list of commands follows. There are three different kinds of commands: 

ENQUEUE x - enter element x into the team queue 
DEQUEUE - process the first element and remove it from the queue 
STOP - end of test case 
The input will be terminated by a value of 0 for t. 

 

Output
For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 
 

Sample Input
  
  
2 3 101 102 103 3 201 202 203 ENQUEUE 101 ENQUEUE 201 ENQUEUE 102 ENQUEUE 202 ENQUEUE 103 ENQUEUE 203 DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 2 5 259001 259002 259003 259004 259005 6 260001 260002 260003 260004 260005 260006 ENQUEUE 259001 ENQUEUE 260001 ENQUEUE 259002 ENQUEUE 259003 ENQUEUE 259004 ENQUEUE 259005 DEQUEUE DEQUEUE ENQUEUE 260002 ENQUEUE 260003 DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 0
 

Sample Output
  
  
Scenario #1 101 102 103 201 202 203 Scenario #2 259001 259002 259003 259004 259005 260001
思路:先把每一个团体对应一个标号,每一个标号对应一个队列数组,当属于同一个团队的就进入同一个队列数组
#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<map>
using namespace std;
int main()
{
    int n, m;
    int t, kcase = 1;
    char str[20];
    bool vis[1002];
    while(scanf("%d",&n),n)
    {
        queue<int> q[1002],que;
        map<int,int> team;
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&m);
            while(m--)
            {

                scanf("%d",&t);
                team[t] = i;
            }
        }
        memset(vis,false,sizeof(vis)); 
        printf("Scenario #%d\n",kcase++);
        while(scanf("%s",str)){
            if(str[0] == 'S'){
			      printf("\n"); 
                  break;
            } 
            else if(str[0] == 'E')
            {
                scanf("%d",&t);
                q[team[t]].push(t);
                if(!vis[team[t]]){
                    que.push(team[t]);
                    vis[team[t]] = true;
                }
            }
            else
            {
                printf("%d\n",q[que.front()].front());
                q[que.front()].pop();
                if(q[que.front()].empty())
                {
                    vis[que.front()] = false;
                    que.pop();
                }
            }
        }  
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值