时间限制:1 秒
内存限制:128 兆
特殊判题:否
提交:974
解决:405
题目描述:
Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.
When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.
One day, Kitty found that there was a crack in the wall. The shape of the crack is
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.
Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?
输入:
The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).
输出:
For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.
样例输入:
5 3
3 2 1
5 2
2 1
样例输出:
2
impossible
/*
//题目大意:一个长方形洞1*L,有N块1*W[i]的木块
//去修补漏洞,求尽量少的木块数
*/
//木块越长优先
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX = 605;
int width[MAX];
typedef long long LL;
LL L;//总长度
int N;//木块数
inline bool cmp(int x,int y)
{
return x>y;
}
int
main(void)
{
while(~scanf("%ld%d",&L,&N))
{
int i;
LL sum = 0;//各木块总长度
//输入
for(i=0;i<N;i++)
{
scanf("%d",&width[i]);
sum += width[i];
}
if(sum < L)
{
printf("impossible\n");
}
else
{
//排序
int count = 0;//木块使用数
sort(width,width+N,cmp);
//使用
for(i=0;i<N;i++)
{
if(L){
if(L-width[i]<0)
L = 0;
else
L -= width[i];
count++;
}
else
{
break;
}
}
printf("%d\n",count);
}
}
return 0;
}
/**************************************************************
Problem: 1436
User: ranchothu
Language: C++
Result: Accepted
Time:10 ms
Memory:1520 kb
****************************************************************/