UVa-OJ11300:Spreading the Wealth

F:Spreading the Wealth

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

Problem setter: Josh Bao


分析:如图A1-n 表示n个人,x1表示A1需要给An的(对于A1给An后An再给A1直接记为A1给An x1个,x1可为负即表示An给A1 x1个),其余类似

      又最终状态是Avg = sum(A1-An)/n

      则Avg = A1-x1+x2  x2 = Avg+x1-A1  令A1-Avg=C1 则x2 = x1-C1

      类似有x3=x1-C2(C2=C1+A2-Avg) .....xn-1=x1-Cn-1

      而交换数量为|x1|+|x1-C1|+...|x1-Cn-1|,最小的情况便是x1={C1-n的中位数}

代码:

//11300 - Spreading the Wealth
#include<cstdio>
#include<algorithm>
using namespace std;

const int MAX = 1000000 + 10;

typedef long long LL;

LL C[MAX];//每个人的财产
LL sum;//所有财产和 
LL ans;//结果 
LL avg;//平均 
int N;

int
main(void)
{
	while(~scanf("%d",&N))
	{
		int i;
		C[0] = 0;
		sum = 0;
		ans = 0;
		for(i = 1;i <= N; ++i)
		{
			LL temp;
			scanf("%lld",&temp);
			sum += temp;
			C[i] = C[i-1] + temp;	
		}

		avg = sum / N; 
		for(i = 1;i < N; ++i)
			C[i] -= i*avg;
		
		sort(C,C+N);//排序 
		
		LL x1 = C[N/2]; 
	
		//求和
		for(i = 0;i < N; ++i)
		{
			ans += abs(x1-C[i]);
		}
		
		printf("%lld\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值