[USACO]Palindromic Squares

13 篇文章 0 订阅
Palindromic Squares
Rob Kolstad

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696

题目大意为求某数在B进制下平方结果为回文,求此数及平方结果(以B进制表示)。
分两步:首先是求某数在B进制下的平方运算。
然后就是判断结果是否为回文。

import java.io.BufferedReader;
import java.io.FileNotFoundException;
import java.io.FileReader;
import java.io.FileWriter;
import java.io.IOException;
//brute force
public class palsquare {
	//first of all,should cal the Palindrome on base 10
	public static void main(String[] args) throws FileNotFoundException,IOException{
		long start = System.currentTimeMillis();
		BufferedReader br = new BufferedReader(new FileReader("palsquare.in"));
		FileWriter fout = new FileWriter("palsquare.out");
		int base = Integer.parseInt(br.readLine());
		String tmp = null;
		for(int i =1;i<300;i++){
			tmp = convert(base,i*i);
			if(isPal(new String(""+tmp))){
				fout.write(convert(base,i)+" "+tmp+"\n");
			}
		}
		fout.flush();
		fout.close();
		br.close();
		long end = System.currentTimeMillis();
		System.out.println(end-start);
		System.exit(0);
		
	}
	private static boolean isPal(String n){
		for(int i =0;i<n.length()/2;i++){
			if(n.charAt(i)!=n.charAt(n.length()-1-i))
				return false;
		}
		return true;
	}
	//convert number n in base 10 to relevent number in base b
	private static String convert(int b,int n){
		if(b==10){
			return new String(""+n);
		}else if(b<10){
			StringBuffer sb = new StringBuffer();
			while(n>0){
				sb.append(n%b);
				n /=b ;
			}
			return sb.reverse().toString();
		}else{
			StringBuffer sb = new StringBuffer();
			int tmp ;
			while(n>0){
				tmp = n%b;
				if(tmp<10){
					sb.append(tmp);
				}else{
					sb.append((char)('A'+(tmp-10)));
				}
				n/=b;
			}
			return sb.reverse().toString();
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值