hdu 1002

/**
* A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 282137 Accepted Submission(s): 54300

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means
the number of the test case. The second line is the an equation “A + B = Sum”, Sum means
the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

  • */
    这道题涉及到大数的运算,用c++写会很麻烦,但由于Java中有大整数类,所以很容易的实现了。不过,这道题之前提交的时候一直是“presentation error”,后来去掉了system.out.printf里的换行符,改用system.out.println就可以了。但不知道为什么,还需要再看看

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int T = sc.nextInt();
        BigInteger a;
        BigInteger b;
        BigInteger res;
        for(int i=0;i<T;i++){
            a = sc.nextBigInteger();
            b = sc.nextBigInteger();
            res = a.add(b);
            System.out.printf("Case %d:",i+1);
            System.out.println();
            System.out.print(a);
            System.out.print(" + ");
            System.out.print(b);
            System.out.print(" = ");
            System.out.print(res);
            System.out.println();
            if(i!=T-1) System.out.println();
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值