题目11:Sort

http://ac.jobdu.com/problem.php?cid=1040&pid=10

题目描述:

给你n个整数,请按从大到小的顺序输出其中前m大的数。

输入:

每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。

输出:

对每组测试数据按从大到小的顺序输出前m大的数。

样例输入:
5 3
3 -35 92 213 -644
样例输出:
213 92 3
// 题目11:Sort.cpp: 主项目文件。

#include "stdafx.h"
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
using namespace std;

const int N=1000003;
bool hashTable[N];
#define more 500000

int main()
{
    //freopen("F:\\test.txt","r",stdin);
    //freopen("F:\\output.txt","w",stdout);
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(hashTable,0,sizeof(hashTable));
		for(int i=0;i<n;i++)
		{
			int tmp;
			cin>>tmp;
			hashTable[more+tmp]=true;
		}
		int cnt=0;
		bool flag=true;
		for(int i=N-1;i>=0;i--)
		{
			if(hashTable[i])
			{
				cnt++;
				if(flag)
				{
					flag=false;
					printf("%d",i-more);
				}
				else
					printf(" %d",i-more);
			}
			if(cnt==m)
				break;
		}
		printf("\n");
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值