UsacoTraining Chapter1.3 Palindromic Squares

Palindromic Squares
Rob Kolstad

Palindromes are numbers that read the same forwards as backwards.The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all theintegers N (1 <= N <= 300 base 10) such that the square of N ispalindromic when expressed in base B; also print the value of thatpalindromic square. Use the letters 'A', 'B', and so on to representthe digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. Thefirst integer is the number whose square is palindromic;the second integer is the square itself. NOTE WELL THATBOTH INTEGERS ARE IN BASE B!

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696
题意:1-300中,如果一个数的平方的x进制下是回文数,就输出该数的x进制和它的平方的x进制

解法:由于数据范围小,直接暴力穷举即可

/*
ID: nflsjxc1
TASK: palsquare
LANG: C++                 
*/
#include<bits/stdc++.h>

using namespace std;

int b;

char m[]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E','F','G','H','I','J','K','L','M','N'};

string change(int i)
{
	stack<char>tmp;
	int t=i;
	while(i!=0)
	{
		tmp.push(m[i%b]);
		i/=b;
	}
	string ret="";
	while(!tmp.empty())
	{
		ret+=tmp.top();
		tmp.pop();
	}
	return ret;
}

bool hw(string str)
{
	for(int i=0,j=str.size()-1;i<=j;i++,j--)
	{
		if(str[i]!=str[j])return 0;
	}
	return 1;
}

int main()
{
	freopen("palsquare.in","r",stdin);
	freopen("palsquare.out","w",stdout);
	ios::sync_with_stdio(0);

	cin>>b;
	
	for(int i=1;i<=300;i++)
	{
		string str=change(i*i);
		if(hw(str))
		{
			cout<<change(i)<<' '<<str<<'\n';
		}
	}

	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值