UVA_100 The 3n+1 problem

UVA_100: The 3n + 1 problem
Time Limit: 3000 MS Memory Limit: 0 MB 64bit IO Format: %lld
Submitted: 10 Accepted: 5
[Submit][Status][Web Board]
Description
Background
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
The Problem
Consider the following algorithm:

    1.       input n
    2.       print n
    3.       if n = 1 then STOP
    4.               if n is odd then  tex2html_wrap_inline44 
    5.               else  tex2html_wrap_inline46 
    6.       GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.
Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no operation overflows a 32-bit integer.
Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

解题代码

#include<iostream>
using namespace std;

int main()
{
    int n,m,t,sum,flag;

    while(cin>>n>>m)
    {
        cout<<n<<" "<<m<<" ";
        if(n>m)//2个数从小到大排序
        {
            t=n;
            n=m;
            m=t;
        }
        flag=0;
        for(int i=n;i<=m;++i)
        {
            int x=i;sum=1;
            while(x-1)
            {//3n+1运算
                if(x%2!=0)
                   x=3*x+1;
                else
                    x/=2;
                sum++;
            }
            if(sum>flag)//选择最大的循环次数
                flag=sum;
        }

        cout<<flag<<endl;
    }
    return 0;
}

这道题目首先是看懂题意,本题是输入2个整数,计算2个整数之间最大的那个循环做3n+1操作的次数。
我们先输入2个整数,由于不知道2个整数的大小关系,我们先按从小到大排个序,再在这2个数之间做循环,找到一个整数,它的做3n+1运算循环次数最大,就输出这个数。
注意2点
1.输入的数大小顺序不知道;
2.要比较循环次数,选择最大的输出;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值