2016湘潭邀请赛 XTU 1243 2016

2016

Accepted : 117 Submit : 438
Time Limit : 2000 MS Memory Limit : 65536 KB

2016

Given a 2×2 matrix

A=(a11a21a12a22),
find An where A1=A,An=A×An1 . As the result may be large, you are going to find only the remainder after division by 7 .

Special Note: The problem is intended to be easy. Feel free to think why the problem is called 2016 if you either:

  1. find it hard to solve;
  2. or, solved all the other problems easily.

Input

The input contains at most 40 sets. For each set:

The first line contains an integer n ( 1n<10100000 ).

The second line contains 2 integers a11,a12 .

The third line contains 2 integers a21,a22 .

( 0aij<7 , (a11a22a12a21) is not a multiple of 7 )

Output

For each set, a 2×2 matrix denotes the remainder of An after division by 7 .

Sample Input

2
1 1
1 2
2016
1 1
1 2

Sample Output

2 3
3 5
1 0
0 1
 
        
 
        
题目的这句话Feel free to think why the problem is called 2016 if you either:可以猜到循环节是2016
 
        
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
char x[100005];
int main()
{
                int n;
                while(~scanf("%s",x))
                {
                                n=0;
                                int t=strlen(x);
                                for(int i=0;i<t;i++)
                                {
                                                n=(n*10+x[i]-'0')%2016;
                                }
                                //printf("%d\n",n);
                                int a,b,c,d;
                                cin>>a>>b>>c>>d;
                                int a1,b1,c1,d1;
                                a1=a;
                                b1=b;
                                c1=c;
                                d1=d;
                                for(int i=1;i<n;i++)
                                {
                                                int a2=a1;
                                                int b2=b1;
                                                int c2=c1;
                                                int d2=d1;
                                          a1=(a*a2+b*c2)%7;
                                          b1=(a*b2+b*d2)%7;
                                          c1=(c*a2+d*c2)%7;
                                          d1=(c*b2+d*d2)%7;

                                }
                                if(n==0)
                                {
                                                a1=1;
                                                b1=0;
                                                c1=0;
                                                d1=1;
                                }
                                cout<<a1<<" "<<b1<<endl<<c1<<" "<<d1<<endl;
                }
                return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值