poj1364(91/600)

11 篇文章 0 订阅
2 篇文章 0 订阅

King
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13778 Accepted: 4887
Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: “If my child was a son and if only he was a sound king.” After nine months her child was born, and indeed, she gave birth to a nice son.
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son’s skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, …, aSi+ni} of a sequence S = {a1, a2, …, an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + … + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + … + aSi+ni < ki or aSi + aSi+1 + … + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.
Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king’s decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.
Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last “null” block of the input.
Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0
Sample Output

lamentable kingdom
successful conspiracy

这个题就是问你存不存在这种序列

可以直接用一个不存在的前缀和来判断
然后就是那一套

不过可以在最短路里判断一下取最大还是最小的…

最大的就是最长路
最短的就是最短路

//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
using namespace std;
//#define int long long 
const int INF = 0x3f3f3f3f;  
const int maxn = 209001;  
int n, m,t;  
struct edge  
{  
    int v, w, next;  
}Edge[2000000];  
int head[maxn], dis[maxn], time[maxn], cnt;  
bool vis[maxn];  
void add_Edge(int u, int v, int w)  
{  
    Edge[cnt].v = v;  
    Edge[cnt].w = w;  
    Edge[cnt].next = head[u];  
    head[u] = cnt++;  
}  
int spfa(int s, int tol)  
{  
    memset(dis, 63, sizeof(dis));  
    memset(time, 0, sizeof(time));  
    memset(vis, false, sizeof(vis));  
    dis[s] = 0;  
    vis[s] = true;  
    time[s]++;  
    queue<int> q;  
    q.push(s);  
    while(!q.empty())  
    {  
        int tem = q.front();  
        q.pop();  
        vis[tem] = false;  
        for(int i = head[tem]; i != -1; i = Edge[i].next)  
        {  
            int to = Edge[i].v;  
            if(dis[to] > dis[tem] + Edge[i].w)  
            {  
                //cout << "yes\n";  
                dis[to] = dis[tem] + Edge[i].w;  
                if(!vis[to])  
                {  
                    vis[to] = true;  
                    q.push(to);  
                    time[to]++;  
                    if(time[to] >= tol)  
                        return 1;  
                }  
            }  
        }  
    }  
    return 0;  
}  
int main()  
{
    string e;
    int n,m,q,w,r;
    while(cin>>n)
    {
        if(!n)break;
        cin>>m;
        memset(head,-1,sizeof(head));
        cnt=0;
        for(int a=1;a<=m;a++)
        {
            cin>>q>>w>>e>>r;
            if(e=="gt")add_Edge(q+w,q,-r-1);
            else add_Edge(q,q+w,r-1);
        }
        for(int a=1;a<=n;a++)add_Edge(0,a,0);
        int tt=spfa(0,n+1);
        if(tt) printf("successful conspiracy\n");
        else printf("lamentable kingdom\n");
    } 
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值