[Coding by C++] 数字黑洞 (20分)

问题描述

  给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。

  例如,我们从6767开始,将得到

    7766 - 6677 = 1089
    9810 - 0189 = 9621
    9621 - 1269 = 8352
    8532 - 2358 = 6174
    7641 - 1467 = 6174
    … …
  现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。

输入格式:
  输入给出一个 (0,10​4​ ) 区间内的正整数 N。

输出格式:
  如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。

输入样例 1:

6767

输出样例 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 =6174

输入样例 2:

2222

输出样例 2:

2222 - 2222 = 0000

实现代码

#include<iostream>
#include<algorithm>
using namespace std;

bool cmp(char a, char b) {
	return a > b;
}
int main() {
	string str1;
	cin >> str1;
	if (str1.size() != 4) {
		int b = 4 - str1.size();
		for (int i = 0; i < b; i++) {
			str1 = "0" + str1;
		}
	}
	if (str1[0] == str1[1] && str1[0] == str1[2] && str1[0] == str1[3]) {
		cout << str1 << " - " << str1 << " = 0000";
		return  0;
	}
	string str2 = str1;
	sort(&str1[0], &str1[4], cmp);
	sort(&str2[0], &str2[4]);
	string str3 = "    ";
	while (1) {
		cout << str1 << " - " << str2 << " = ";
		for (int i = 0; i < 4; i++) {
			if (str1[3 - i] - str2[3 - i] >= 0) {
				str3[3 - i] = str1[3 - i] - str2[3 - i] + '0';
			}
			else {
				str3[3 - i] = str1[3 - i] + 10 - str2[3 - i] + '0';
				int index = i + 1;
				while (str1[3 - index] == '0') {
					str1[3 - index] = '9';
					index++;
				}
				str1[3 - index]--;
			}
		}
		cout << str3 << endl;
		if (str3 == "6174") {
			return 0;
		}
		str1 = str3;
		str2 = str3;
		sort(&str1[0], &str1[4], cmp);
		sort(&str2[0], &str2[4]);
	}
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值