深搜---Sum it up

3 篇文章 0 订阅

Sum It Up

Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25


题意理解:  首先输入两个数据T,n,前一个是代表数字总和,后一个是要求输入的数据的个数。
            题目要求将输入的数据按个数大小排列,总和为T的不同组成按列输出,如果这些数不能组成T,就输出NONE。
解题思路:  深搜题,剪枝的时候需要跳过曾经搜索过的相同的数目,既满足a[i]==a[i-1]&&v[i-1]==0,v[i-1]==0可以说明该点已经测试过。
            因为题目要求按照输入的数组顺序输出,则不需排序,直接搜索,每次搜索的和如果符合要求,则输出答案。
code:
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
int a[1005];
int v[1005];
int n,T;
void print()
{
    int j=0;
    for(int i=0;i<n;i++)
    {
        if(j&&v[i])
            printf("+%d",a[i]);
        if(j==0&&v[i])
        {
            printf("%d",a[i]);
            j=1;
        }
    }
    printf("\n");
}

int judge(int num,int sum)
{
    if(num<0||num>=n||v[num]||sum+a[num]>T)
        return 0;
    return 1;
}

int DFS(int k,int sum)
{
    int i,flag=0;
    if(sum==T)
    {
        print();
        return 1;
    }
    for(i=k;i<n;i++)
    {
        if(i>k&&a[i]==a[i-1]&&v[i-1]==0)
            continue;
        if(judge(i,sum))
        {
            v[i]=1;
            if(DFS(i+1,sum+a[i]))
                flag=1;
            v[i]=0;
        }
    }
    return flag;
}
int main()
{
    while(scanf("%d%d",&T,&n)!=EOF&&(T||n))
    {
        int flag=0;
        memset(v,0,sizeof(v));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        printf("Sums of %d:\n",T);
        flag=DFS(0,0);
        if(flag==0)
          printf("NONE\n");

    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值