【hdoj 3371】Connect the Cities

Connect the Cities
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12877 Accepted Submission(s): 3545


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.


Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.



Output
For each case, output the least money you need to take, if it’s impossible, just output -1.


Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6


Sample Output

1


题意理解:

修路,使所出费用最少。

有多组测试数据,n个结点,m组可以修建的道路,开始点  终点  费用

k组联通的道路,每组有t个结点

输出使所有结点都联通,输出最少的用来修路的钱

解题思路:

最少的路有n-1条,将联通的点加入同一集合。kruskal算法算出需要使用的钱的最小值。


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
#include <stack>
#include <queue>
#define INF 65535
using namespace std;
int pre[505];
struct node
{
    int u;
    int v;
    int val;
}e[25001];
int n,m,num;
int cmp(node i,node j)
{
    return i.val<j.val;
}
void init(int n)
{
    for(int i=1;i<=n;i++)
        pre[i]=i;
}
int Find(int x)
{
	int r = x;
	while(pre[r]!=r)
        r = pre[r];
    return r;
}
int kruskal()
{
    int ans = 0;
    sort(e+1,e+m+1,cmp);
    for(int i=1;i<=m;i++)
    {
        int x=Find(e[i].u);
        int y=Find(e[i].v);
        if(x==y)
        {
            continue;
        }
        ans+=e[i].val;
        pre[x]=y;
        ++num;
        if(num==n-1)
            break;
    }
    if(num==n-1)
        return ans;
    return -1;


}
int main()
{
    int k,ci,t,p,q,c,one;
    int Test;
    scanf("%d",&Test);
    while(Test--)
    {
        num = 0;
        scanf("%d%d%d",&n,&m,&k);
        init(n);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&p,&q,&c);
                e[i].u = p;
                e[i].v = q;
                e[i].val = c;
        }
        for(int i=0;i<k;i++)
        {
            scanf("%d",&t);
            scanf("%d",&one);
            int y = Find(one);
            for(int j=1;j<t;j++)
            {
                scanf("%d",&ci);
                int x = Find(ci);
                if(x!=y)
                {
                    pre[x] = y;
                    ++num;
                }
            }
        }
        if(num == n-1)
        {
            printf("0\n");
            continue;
        }
        int mincost=kruskal();
        printf("%d\n",mincost);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值