【uva 11021】Tribbles

Tribbles
Input: Standard Input

Output: Standard Output

GRAVITATION, n.
"The tendency of all bodies to approach one another with a strength
proportion to the quantity of matter they contain -- the quantity of
matter they contain being ascertained by the strength of their tendency
to approach one another. This is a lovely and edifying illustration of
how science, having made A the proof of B, makes B the proof of A."

Ambrose Bierce

You have a population of k Tribbles. This particular species of Tribbles live for exactly one day and then die. Just before death, a single Tribble has the probability Pi of giving birth to i more Tribbles. What is the probability that after m generations, every Tribble will be dead?

Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing n (1<=n<=1000), k (0<=k<=1000) and m (0<=m<=1000). The next n lines will give the probabilities P0, P1, ..., Pn-1.

Output

For each test case, output one line containing "Case #x:" followed by the answer, correct up to an absolute or relative error of 10-6.

Sample InputSample Output
4

3 1 1

0.33

0.34

0.33

3 1 2

0.33

0.34

0.33

3 1 2

0.5

0.0

0.5

4 2 2

0.5

0.0

0.0

0.5
Case #1: 0.3300000

Case #2: 0.4781370

Case #3: 0.6250000

Case #4: 0.3164062


题意:毛球族死后可以变成0~n-1个毛球,概率为P0~Pn-1,原本有k个毛球,问m天后毛球族灭绝的概率

解题思路:每个个体是独立的,所以只需先求一个毛球在m天后灭绝的概率,将毛球在1天之后灭绝的概率,2天之后灭绝的概率,3天之后.。。。。推出m天后灭绝的概率。

code:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <map>
using namespace std;

int main()
{
    int N;
    scanf("%d",&N);
    double  p[1005];
    double  mp[1005];
    int n,m,k;
    double ans;
    for(int cnt=1;cnt<=N;cnt++)
    {
        ans=0.0;
        scanf("%d%d%d",&n,&k,&m);
        for(int i=0;i<n;i++){
            scanf("%lf",&p[i]);
        }
        if(!k)
           printf("Case #%d: 1.0000000\n",cnt);
        else if(!m)
           printf("Case #%d: 0.0000000\n",cnt);
        else{
            memset(mp,0,sizeof(mp));
            mp[1]=p[0];
            for(int i=2;i<=m;i++){
                for(int j=0;j<n;j++){
                    mp[i]+=(double)(p[j]*pow(mp[i-1],j));
                }
            }
            ans=pow(mp[m],k);
            printf("Case #%d: %.7lf\n",cnt,ans);
        }
    }
    return 0;
}















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值