hdu2071

说明:

1. 浮点数是可以直接比较大小的,用于if判断

2. printf(“%.2f",...


/*
 * =====================================================================================
 *
 *       Filename:  hdu2071.c
 *
 *
 *        Version:  1.0
 *        Created:  2013年11月19日 14时48分00秒
 *       Revision:  none
 *       Compiler:  gcc
 *
 *         Author:  Wenxian Ni (Hello World~), niwenxianq@qq.com
 *   Organization:  AMS/ICT
 *    Description:  
Max Num

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11527    Accepted Submission(s): 7381


Problem Description
There are some students in a class, Can you help teacher find the highest student .
 

Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
 

Output
For each case output the highest height, the height to two decimal plases;
 

Sample Input
2
3 170.00 165.00 180.00
4 165.00 182.00 172.00 160.00
 

Sample Output
180.00
182.00
 *
 * =====================================================================================
 */

#include <stdio.h>

int main()
{
    int ncase;
    int n;
    float height, max_he;
    scanf("%d",&ncase);
    while(ncase--)
    {
        max_he = 0;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%f",&height);
            if(height > max_he)
                max_he = height;
        }
        printf("%.2f\n",max_he);

    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值