最大子段和

给出N个数字, 计算出最大的子段和。

Input

第一行给出一个数字 T(1<=T<=20) 代表接下来的组数.
接下来每 T 行,开始给出一个数组 N(1<=N<=100000), 接着跟着N个数字.

数据保证最后结果小于2^31.

Output

输出最大的字段和



Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output
14
7

#include<iostream>

using namespace std;

#define MAX 10001

void vInput(int nN,int nA[]);
int nGetMax(int nN,int nA[]);
void vOutput(int nOut);

int main()
{
int nCase;
int nNum;
int nAns;
int i;
int nArr[MAX];

scanf("%d",&nCase);
for(i=1;i<=nCase;i++)
{
scanf("%d",&nNum);
vInput(nNum,nArr);
nAns=nGetMax(nNum,nArr);
vOutput(nAns);
}
return 0;
}

void vInput(int nN,int nA[])
{
int i;

for(i=1;i<=nN;i++)
{
scanf("%d",&nA[i]);
}
}

int nGetMax(int nN,int nA[])
{
int nMax;
int nCurrentNum;
int i;

nCurrentNum=0;
nMax=0;
for(i=1;i<=nN;i++)
{

if(nCurrentNum>=0)
{
nCurrentNum+=nA[i];
}
else
{
nCurrentNum=nA[i];
}

if(nMax<nCurrentNum)
nMax=nCurrentNum;
}
return nMax;
}

void vOutput(int nOut)
{
printf("%d\n",nOut);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值