Floyed-Arbitrage POJ - 2240

Floyed-Arbitrage POJ - 2240

题目:
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No

题意:
通过一系列的货币之间的汇率兑换看能否获利。
输入货币种类数量n,输入各种货币名。(点的数量)
输入可兑换的方式的数量m,输入各种货币之间的汇率。(路和路的数量)
输出是否能够获利。

思路:
判断正环。
考虑到n<=30,用Floyed算法。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<map>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=35;
int n,m,k=0;
double a[maxn][maxn];
string name;
map<string,int>p;

int main()
{
    while(cin>>n)
    {
        if(!n) return 0;
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            cin>>name;
            p[name]=i;//每种货币一个编号
            a[i][i]=1.0;//初始化
        }
        cin>>m;
        for(int i=1;i<=m;i++)
        {
            string tmp1,tmp2;
            double exc;
            cin>>tmp1;
            cin>>exc;
            cin>>tmp2;
            int u=p[tmp1],v=p[tmp2];
            a[u][v]=exc;
        }

        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    a[i][j]=max(a[i][j],a[i][k]*a[k][j]);//考虑经过货币k,货币i兑换到货币j的汇率

        bool flag=false;
        for(int i=1;i<=n;i++)
            if(a[i][i]>1)//自己到自己钱变多
                flag=true;
        if(flag) printf("Case %d: Yes\n",++k);
        else printf("Case %d: No\n",++k);
    }
    return 0;
}

总结:

  1. 邻接矩阵判断正环:a[i][i]>1
  2. map的使用,将每个string对应一个编号
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值