HDU 1010 Tempter of the Bone(深搜+剪枝)

Tempter of the Bone

                                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                  Total Submission(s): 126795    Accepted Submission(s): 34190


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES


这题搜索很好写,但是剪枝要都能想到:

①某一点(X,Y)到终点的最短距离应该小于等于剩余的能量

②规律:某一点到终点的最短距离的奇偶性决定了它无论怎么走所花费的步数都一定是那个奇偶性

   所以,剩余能量的奇偶性一定与当前点到终点的最短距离的奇偶性相同

③可以走的点的数目一定要大于等于总共的能量数

写好这几点,AC稳了。(直接去写就好,有兴趣看看代码)


#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

char map[8][8];
int vis[8][8];
int n,m;
int sx,sy,ex,ey;//开始点终点坐标
int ne[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};
int t;

bool dfs(int x, int y, int step)
{
    if(step> t) 
		return 0; 
    if(map[x][y] == 'D'&&step == t)
    	return 1;
    if(((abs(x - ex) + abs(y - ey)) &1) != ((t-step) &1) || abs(x - ex) + abs(y - ey)> t-step) //对应①②
		return 0;
    for(int k = 0; k < 4; k++)
    {
        int tx = x + ne[k][0];
        int ty = y + ne[k][1];
        if(tx< 0||tx>= n||ty< 0||ty>= m||map[tx][ty] == 'X'||vis[tx][ty])
			continue;
        vis[tx][ty] = 1;
    	if(dfs(tx,ty,step+1)) 
			return 1;
        vis[tx][ty] = 0;
    }
    return 0;
}

int main()
{
    while(~scanf("%d %d %d",&n,&m,&t)&&(m||n||t))
    {
    	memset(vis,0,sizeof(vis));
        int count = 0;
        for(int i = 0; i < n; i++)
            scanf("%s", map[i]);
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
            {
                if(map[i][j] == 'X')//把X都记录下来
                    count++;
                if(map[i][j] == 'S')
                {
                    sx = i; sy = j;
                    vis[i][j] = 1;
                }
                else if(map[i][j] == 'D')
                {
                    ex = i;ey = j;
                }
        	}
        if(n * m - count < t|| !dfs(sx, sy, 0)) puts("NO");//③条件不满足,直接NO
        else puts("YES");
    }
    return 0;
}

精写文章阅读


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值