hdu1171Big Event in HDU(01背包或多重背包)

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43630    Accepted Submission(s): 14999


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40


这个题数据量不是特别大,直接转换成01背包做就可以。多重背包二进制,可以去搜下学习。

说白了就是,任何数都可以用二进制0,1表示,所以任何一个数m = 2^i+2^j这样表示,所以这

样可以枚举完所有的可能。

01背包:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<map>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;
const int maxn = 5e5+5;
const int ff = 0x3f3f3f3f;

int n;
int w[maxn],v[maxn];
int dp[maxn];

int main()
{
	while(~scanf("%d",&n)&&(n> 0))
	{
		mem(dp,0);
		mem(w,0);
		mem(v,0);
		int sum = 0;
		for(int i = 1;i<= n;i++)
		{
			scanf("%d %d",&w[i],&v[i]);
			sum+= w[i]*v[i];
			if(v[i]> 1)
			{
				int j = i; 
				while(v[j]> 1)//把其拆成几个,看成不一样的元素来处理。
				{
					w[++i] = w[j];
					v[j]--;
					n++;
				}
			}
		}
		int m = sum/2;
		for(int i = 1;i<= n;i++)
			for(int j = m;j>= w[i];j--)
				dp[j] = max(dp[j],dp[j-w[i]]+w[i]);
		sum-= dp[m];
		printf("%d %d\n",sum,dp[m]);
	}
	
	
	return 0;
}

多重背包:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<map>
#include<cmath>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;
const int maxn = 1e3+5;
const int ff = 0x3f3f3f3f;
typedef struct
{
	int price;
	int num;
} node;

node a[100];
int n;
int dp[300001];

int main()
{
	while(~scanf("%d",&n)&&(n> 0))
	{
		mem(dp,0);
		int sum = 0;
		for(int i = 1;i<= n;i++)
			scanf("%d %d",&a[i].price,&a[i].num),sum+= a[i].price*a[i].num;
		int m = sum/2;
		for(int i = 1;i<= n;i++)
		{
			int k = 1,num = a[i].num;
			while(num> k)
			{
				for(int j = m;j>= a[i].price*k;j--)
					dp[j] = max(dp[j],dp[j-a[i].price*k]+a[i].price*k);
				num-= k;
				k*= 2;//翻着番地增加
			}
			for(int j = m;j>= a[i].price*num;j--)//处理剩下的
				dp[j] = max(dp[j],dp[j-a[i].price*num]+a[i].price*num);
		}
		sum-= dp[m];
		printf("%d %d\n",sum,dp[m]);
	}
	return 0;
}

很多文章呢


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值